Pendrive vs. Pendrive a obraz.iso

Ostatnio miałem problem z nagraniem obrazu.iso , powiedzie co w tym dziwnego? zacznę od początku…najpierw pobieram obraz, obojętnie jakiej distr. Linuksa. Następny mój krok to nagranie na nośnik pamięci. Kiedyś to by była płyta CD lub DVD, ale powoli przechodzi do zapomnienia, coraz więcej komputerów nie ma nawet jak odtworzyć takiej płyty. W dzisiejszych czasach aktualne są karty pamięci, dyski przenośne i pendrive’y, temat przewodni mojego wpisu.

Taka sytuacja…

Pobrałem obraz, wybrałem pendrive, na którym chcę skopiować obraz.iso, uruchomić i zainstalować „Linux’a”. Zawsze nagrywam poprzez terminal, czyli:

dd if=/ścieżka do/pliku.iso of=/dev/sd?

Można określić, że jak w taki sposób skopiujemy to musi zakończyć się powodzeniem, też tak myślałem. Bierzemy pod uwagę, że Bios prawidłowo ustawiony czyli pendrive widzi itd. a obraz jest bez błędu.

Uruchamiam laptop na pendrive nr.1 i co ?! niestety błąd.

Skąd ? przecież na tym kompie uruchamiałem na rożnych pendrive’ach „Linux’y” – wszystko powinno działać. No dobrze, sprawdzam na drugim nośniku – pendrive nr.2. Nagrywam tak samo i ten sam obraz. Uruchamiam i … działa , wszystko prawidło, uruchomiło się. Oba pendrive’y działają prawidło, kopiowanie plików i otwieranie jest ok, tylko przy kopiowaniu obrazu.iso pendrive nr.1 „ma problemy”.

Już wyjaśniam, Pendrive nr.1 dostałem na jakieś imprezie jako gadżet, co firmy rozdawają, że swoim Logiem – nie ma nazwy producenta nośnika. A Pendrive nr.2 to kupiony przeze mnie w sklepie z nazwą producenta nośnika.

Pierwsza myśl, jaka mi się nasunęła, to że Pendrive’y takie jak ten mój nr.1, są nie do końca „dopracowane” lub mają jakieś uszkodzenia. Ale problem tkwi tylko podczas obrazów.iso, a tak działa prawidłowo. Poszukałem w internecie na ten temat… znalazłem że zmiana niektórych plików z iso… na sys… też nie pomogło. Tylko przypomnę ze nr.2 ma te same pliki iso… a działa. A tu rady że na niektórych pendrive’ych trzeba zmieniać niektóre pliki by uruchomić obraz.iso. dlaczego ? Przecież użytkownika interesuje, że po skopiowaniu obrazu.iso będzie działać. A tu okazuje się że są pendrive’y , które potrzebują jakieś naszej ingerencji. Czy pendrive’y rozdawane jako gadżety na … mają jakieś ograniczenia ?! a te kupione w sklepie działają prawidłowo. Może się czepiam, ale co rusz można spotkać kogoś, co ma problem ze skopiowaniem obrazu.iso. Część to problem przez „UEFI” lub coś innego. Postanowiłem ten problem opisać. Jestem ciekawy czy to odosobniony przypadek, czy wy też z tym się spotkaliście ? dajcie znać w komentarzach.

Pozdrawiam.